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Chapter 1: Introduction

MapDesigner Overview
MapDesigner offers a straightforward way to create maps that are used in Alarm 
Monitoring. Each map you create contains icons, small graphical symbols, 
representing access control system hardware components and areas. During 
alarm monitoring, one or more hardware icons may appear animated on a map to 
indicate the presence of alarms at those physical locations.

Using MapDesigner, you can add text information to maps, change the 
appearance of the map icons and labels and, resize and print maps. You can also 
link maps together by creating maps that include icons for other maps. 

Conventions Used in this Documentation
• Where a term is defined, the word is represented in italics.

• Field names, menus, and menu choices are shown in bold. 

• Keyboard keys are represented in angle brackets. For example: <Tab>, 
<Ctrl>.

• Keyboard key combinations are written in two ways:
<Ctrl> + <Z> means hold down the first key, then press the second

<Alt>, <C> means press the first key, then press the second

• Window buttons on the screen are represented in square brackets. For 
example: [OK], [Cancel].

How this Document is Organized
The MapDesigner User Guide is a procedural document designed to help you 
create, modify, and manage maps. The procedures are NOT divided between 
System Administrator and Technician types of procedures.
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1: Introduction
Getting Started 

Passwords

B.A.S.I.S.® ET Third Edition includes strong password enforcement, which 
checks the user’s password against password standards. This functionality is 
designed to enhance password security if single sign-on is not used. If single 
sign-on is used (automatic or manual), B.A.S.I.S. does not enforce password 
standards. For more information on single sign-on, refer to Single Sign-On 
Overview on page 12.

The system’s strong password enforcement also checks the BEST database user’s 
password when logging into applications. Database user passwords apply only to 
Oracle and SQL databases. For information on changing your database password 
refer to the Installation & Setup User Guide.

Password Standards

When creating a strong password keep the following guidelines in mind:

• Passwords cannot be blank.

• Passwords cannot be the same as the user name (e.g. SA, SA).

• Passwords cannot be BEST keywords (e.g. MULTIMEDIA, PROKUPETS, 
PROKUPET, BEST, BASIS, PASSWORD).

• Although not required, your password should contain numbers, letters, and 
symbols. Spaces are also acceptable. (e.g. August 18, 2002).

• B.A.S.I.S. passwords are not case-sensitive.

• Database passwords conform to the rules of the specific database being used; 
passwords in SQL Server and Oracle are case insensitive.

• The maximum value for a strong password is 127 characters. The minimum 
value is 1.

Notes: For Oracle databases the following account username and passwords are not 
allowed to be used together:

System and Manager

Internal and Oracle

Sys and Change_On_Install

Enable/Disable Strong Password Enforcement
Strong password enforcement is enabled/disabled in System Administration or 
ID CredentialCenter. When you install B.A.S.I.S., by default strong password 
enforcement is enabled. When you upgrade, by default strong password 
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enforcement is disabled. To manually enable or disable strong password 
enforcement:

1. Select System Options from the Administration menu in System 
Administration or ID CredentialCenter.

2. Select the General System Options tab.

3. Click [Modify].

4. Select or deselect the Enforce strong passwords checkbox. 

Note: If you disable the option to enforce strong passwords, you will continue to 
receive a message stating your password is weak every time you log into an 
application until you change your B.A.S.I.S. password to meet the password 
standards.

Change User Passwords
User passwords are checked every time a user logs into any application. After a 
user logs into an application he/she can change his/her user password.

1. From the Map menu select Change Password.

2. The Change Password window displays. Enter your old password and new 
password in the appropriate fields. Refer to the Password Standards on page 
8 for guidelines in choosing a secure password. 

3. A message confirms that you have successfully changed your password.

4. Click [OK].

Note: If you get a weak password message the next time you log into the 
application, carefully read the message. It may be telling you that your 
database password is weak and not your user password. To change your 
database password, refer to the Accounts and Passwords Appendix in the 
Installation and Setup User Guide.

Error Messages
Read weak password messages/warnings carefully to avoid confusion about 
whether your user password or database password is weak.

If you have a weak database password you will receive a warning every time you 
log into any application, until you change your database password. Although it is 
not recommended, you can acknowledge the warning and continue working in 
the application. This table describes the password-related error messages that 
may be generated and which password you need to correct.

• To correct the database password, refer to the Installation & Setup User 
Guide.
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• To correct the user password, select a password that meets the standards 
specified in Password Standards on page 8.

Accounts
Anyone who wishes to use B.A.S.I.S. applications must enter a user name and 
password in order to access the software. The System Administrator should 
create a unique account for each user of the applications. The System 
Administrator can also, for each user, create a list of permissions, which specifies 
precisely which screens, fields, and buttons the user can access.

During initial installation of the application, default accounts are created. These 
include:

These are provided as samples. You may change the passwords and use the 
accounts, or remove them. The exception to this is the system account, SA. By 
definition this account has permission to do anything in the system. A user with 
system access has unlimited access to the application. You cannot delete or 
change the system account except to modify the password, which you are 
strongly encouraged to do as soon as possible to discourage unauthorized use.

The first time you log into B.A.S.I.S. to configure the application, you should log 
in as SA and your password should be SA.

Warning message Password 
to correct

Database password violations: Your password is a keyword that is not 
allowed. It is highly recommended that you change your password to 
meet our minimum password standards.

Database

Your password cannot be blank. Enter a password. User

User password violations: Passwords cannot be the same as the user 
name.

User

Your password is a keyword that is not allowed. User

User name Password Type

sa sa system account

admin sample

user sample

badge sample
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Log In
This procedure describes how to log in without using single sign-on. For a 
description of single sign-on, refer to Single Sign-On Overview on page 12. To 
log in using single sign-on, refer to Single Sign-On Procedures on page 13.

1. Click the Start button, then select Programs > B.A.S.I.S. ET > 
MapDesigner.

2. Your system may be configured to prompt you to select a database to log 
into. If it is not, proceed to the next step. If it is:
a. In the Database drop-down, all ODBC system databases currently 

defined on your computer are listed. Select the database that you wish to 
use for your application.

b. Click [OK].

3. The Log On window displays.
a. In the User name field, type the user name assigned to you. When 

logging in for the first time, your user name is SA.
b. In the Password field, type the password assigned to you. When 

logging in for the first time, your password is SA. Note that the 
characters you type do not appear in the field. Instead, for each character 
you type, an “*” displays. This is intended to protect against 
unauthorized access in the event that someone else can see the screen 
while you type.

Important: After logging in for the first time, you are strongly encouraged to modify the 
password for the system account as soon as possible to discourage 
unauthorized use.

c. In the Directory field, select the directory that you wish to log into. For 
user accounts not using single sign-on, the default is “<Internal>.”

d. Select the Remember user name and directory checkbox if you want 
the values you just entered in the User name and Directory fields to 
automatically be selected the next time that you log in.

e. Click [OK].

4. Your system may be configured to prompt you to confirm that you are 
authorized to use the application. To accept the terms of the authorization 
warning click [Yes].

5. If segmentation is not enabled, skip this step. If segmentation is enabled:

a. The Select Segment window opens. Select the segment you wish to log 
into.

b. Click [OK].
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Single Sign-On Overview
Single sign-on simply means logging into B.A.S.I.S. with the same user name 
and password that you use to log into Windows or logging into B.A.S.I.S. using 
an LDAP user name and password for authentication. LDAP (Lightweight 
Directory Access Protocol) is a software protocol that enables you to locate 
businesses, people, files, and devices without knowing the domain name 
(network address).

Single sign-on allows scripts using the OpenIT API to authenticate. These scripts 
will be run under a Windows account. The account that is making the call to the 
API can be obtained easily this way, and the script can be restricted to those 
actions that the user is permitted to perform (using standard B.A.S.I.S. 
permissions).

Note: The use of the explicit username and password for directory authentication 
to Windows is strongly discouraged. It is recommended that you do not store 
Windows passwords in the B.A.S.I.S. system, since B.A.S.I.S. uses 
reversible encryption and Windows does not. If explicit authentication is 
required, you should use an account that has view only permission to the 
directory in question.

Directory Accounts
To log into B.A.S.I.S. using single sign-on, a user name, password, and directory 
is required. A directory is a database of network resources, such as printers, 
software applications, databases, and users. The following directories are 
supported by B.A.S.I.S.: Microsoft Active Directory, Microsoft Windows NT 4 
Domain, Microsoft Windows 2000/XP Workstation, and LDAP.

Automatic and Manual Single Sign-On
When a user account is configured for single sign-on, the user can log into 
B.A.S.I.S. automatically or manually. 

For example, with automatic single sign-on, users simply start B.A.S.I.S. and 
they are automatically logged in under their Windows account and directory. 

With manual single sign-on, users must manually enter their Windows or LDAP 
account information (user name and password). Users also have the option of 
selecting a different configured directory. 

If single sign-on is not used, users manually enter a user name and a password 
that is different from their Windows or LDAP password. The directory is hard-
coded to refer to the internal B.A.S.I.S. user directory. 
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Notes: Manual single sign-on can be used with the following directories: Microsoft 
Active Directory, Microsoft Windows NT 4 Domain, and LDAP.

Automatic single sign-on can be used with every directory supported by 
B.A.S.I.S. except LDAP because it doesn’t provide all the account 
information required.

Single Sign-On Procedures

Configure Single Sign-On
By default, user accounts do not use sign-on. To configure single sign-on the 
System Administrator must add a directory and link a user account to the 
directory. 

Notes: For more information, refer to “Add a Directory” in the Directories folder 
chapter of the System Administration or ID CredentialCenter User Guide.

For more information, refer to “Link a User Account to a Directory 
Account” in the Users folder chapter of the System Administration or ID 
CredentialCenter User Guide.

Log In Using Automatic Single Sign-On
Automatic single sign-on is supported with Windows domain accounts.

1. Click the Start button, then select Programs > B.A.S.I.S. ET > 
MapDesigner.

2. Your system may be configured to prompt you to select a database to log 
into. If it is not, proceed to step 3. If it is:
a. In the Database drop-down, all ODBC system databases currently 

defined on your computer are listed. Select the database that you wish to 
use for your application.

b. Click [OK].

3. If your Windows account is linked to a user, a message will be displayed that 
says, “Attempting to automatically log you on using your Windows account. 
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To bypass this, hold down SHIFT.” To automatically be logged in, do 
nothing.

4. Your system may be configured to prompt you to confirm that you are 
authorized to use the application. To accept the terms of the authorization 
warning, click [Yes].

5. If segmentation is not enabled, skip this step. If segmentation is enabled:

a. The Select Segment window opens. Select the segment you wish to log 
into.

b. Click [OK].
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Log In Using Manual Single Sign-On
Both users who want to log into B.A.S.I.S. using an LDAP user name and 
password for authentication and users who want to log in using a Windows 
domain account can do so using manual single sign-on. 

1. Click the Start button, then select Programs > B.A.S.I.S. ET > 
MapDesigner.

2. Your system may be configured to prompt you to select a database to log 
into. If it is not, proceed to step 3. If it is:
a. In the Database drop-down, all ODBC system databases currently 

defined on your computer are listed. Select the database that you wish to 
use for your application.

b. Click [OK].

3. If your Windows account is linked to a user, a message will be displayed that 
says, “Attempting to automatically log you on using your Windows account. 
To bypass this, hold down SHIFT.” 
To manually login or to login using a different user name and password, hold 
down the <Shift> key. The Log On window opens.

a. In the Directory field, select the directory that you wish to log into. The 
default is “<Internal>.”

b. In the User name field, type the Windows user name assigned to you. 
Do not enter the domain\user name just enter your user name.

c. In the Password field, type the Windows password assigned to you.
d. Select the Remember user name and directory checkbox if you want 

the values you just entered in the User name and Directory fields to 
automatically be selected the next time that you log in.

e. Click [OK].

4. Your system may be configured to prompt you to confirm that you are 
authorized to use the application. To accept the terms of the authorization 
warning, click [Yes].

5. If segmentation is not enabled, skip this step. If segmentation is enabled:
a. The Select Segment window opens. Select the segment you wish to log 

into.
b. Click [OK].

 Troubleshoot Logging In
If you attempted to log in and were unable to do so, make sure that the following 
conditions have been met:
• You entered a correct user name/password and specified the correct 

directory.

• If your system is configured to display an authorization warning, you 
accepted the terms.
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• A valid license is installed. For more information refer to “The License 
Administration Application” appendix in the Installation & Setup User 
Guide.

• You have permission to use the application. 

• If you attempted to log into the server and the login failed, make sure that a 
properly coded, licensed dongle adapter is attached to your computer’s 
parallel port. Make sure that your dongle is securely attached.

• If you attempted to log into a client and failed, make sure the client has a 
valid software license. Client computers do not need a hardware dongle 
attached to the computer’s parallel port. Instead, the client must have a valid 
software license, which is installed in the License Administration 
application.

• If you are using single sign-on, ensure that the directory you are 
authenticating against is operational and properly configured. When a 
directory is properly configured, the accounts are listed on the Select 
Account form when linking a user account to a directory. 

• If you are using single sign-on, ensure that the directory account is properly 
linked to the user account.

Display a Map
There are several ways to display an existing map.

1. In the Map List of the List Window select the name of the map you wish to 
display.

2. Do one of the following:
• Click the Open toolbar button.
• From the Map menu select Load.

Toolbar Shortcut • Double-click the desired map from the Map list.
• Press <Ctrl> + <L> on your keyboard
• Press <Enter> on your keyboard

Note: The Map window holds only one map at a time. If the Map window already 
contains a map the access control system will prompt you to save the first 
map before loading a new one.

Resize the List and Map Windows
The MapDesigner window is divided into two sections separated by a split bar:

• The left section is called the List window. When you first start MapDesigner, 
the List window contains two entries, Maps and System Configuration 
Objects. Each is expandable, as described Map and System Configuration 
Object Lists on page 22.

• The right section is called the Map window. Initially it is empty and is used 
during map creation and display.
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You can move the split bar, thereby changing the relative sizes of the List and 
Map windows. This is useful if you have a large base map, or when you want to 
view expanded lists. There are two ways to reposition the split bar:

Split arrow • Position the mouse pointer over the split bar. The pointer will become a split 
arrow. Click and drag the split bar to the desired position.

• Select Split from the Window menu. The pointer becomes a split arrow on 
top of a split bar. Move the pointer to the desired position then click to 
anchor the split bar.

Log Out of the Application
When you log out of the application the entire application closes.

1. Select Log Off from the Map menu.

2. If a map is open, it automatically closes.If there are unsaved changes you 
will be asked if you want to save the changes before the map closes. 

Note: After you log out of the application the main window remains opened but 
most of the toolbar and menu options are dimmed. To access all the 
application’s features you must log in again.

Exit the Application
You can close and exit the application using the following methods:

• Double-click the icon located in the upper left corner of the title bar. If you 
are prompted to log off click the [Yes] button.

• Single click the icon located in the upper left corner of the title bar and select 
Close. If you are prompted to log of click the [Yes] button.

• Click the close button in the window’s upper right corner. If you are 
prompted to log of click the [Yes] button.

• Select Exit from the Map menu.

• If you have unsaved work, the following message displays:

If this window displays, do one of the following:
– Click the [Yes] button to save changes and close MapDesigner.
– Click the [No] button to abandon changes and close MapDesigner.
– Click the [Cancel] button to continue your MapDesigner session.
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Chapter 2: MapDesigner Main Window

The illustration below shows the MapDesigner window with the List window 
fully expanded and a map loaded into the Map window.

Field Description

Split bar A vertical bar that divides a window and is used to adjust 
the relative sizes of the two subwindows—in this case, the 
List window and Map window.

List window Contains the Maps list—including all maps currently in 
the database, and the System Configuration Objects—
including all currently configured access control system 
hardware components. For more information, refer to 
Map and System Configuration Object Lists on page 22.

Map window Displays either the current map selection or a new map 
being created.

Bounding box A boundary around the right and bottom sides of the map, 
used to resize the map in the Map window.
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Menus and Toolbars
The menu bar is a horizontal list of options that appears at the top of the main 
window. Each option has a drop-down menu. A toolbar is a strip of buttons that is 
positioned by default just below the menu bar. 

Operators can customize how the toolbar displays; they can: 

• Change the toolbar from anchored to floating
Toolbars are anchored by default and are displayed in horizontal rows below 
the menu bar. Anchored toolbars can be changed to floating toolbars, which 
allows the toolbar to be repositioned anywhere in the window. For more 
information, refer to How to Use the Toolbars on page 22.

• Control if the toolbar is displayed
By default the toolbar is displayed. Operators can control if the toolbar 
is displayed by selecting or deselecting Toolbar from the View menu. 
For more information, refer to How to Use the Toolbars on page 22.

Menu Options
Refer to the following tables to identify the options available under each 
menu item as well as the associated toolbar button

Status bar An area along the bottom of the window that contains 
explanatory or status information pertaining to the 
location of the cursor.

Resize button A triangular area containing several diagonal lines, 
located in the lower right corner of a window. Clicking 
and dragging the resize button changes the window’s 
height and width.

Control-menu 
icon

An icon for the associated window, located in the upper 
left corner of the title bar. Clicking the control-menu icon 
displays a menu for moving, resizing, and closing the 
window.

Field Description

Map menu

Menu option Toolbar button Function

New Displays the Open Map Background Image window. Select a map 
background that will be used to create a new map. 

Note: If the user has access to multiple segments, they will 
first be prompted to select the segment the new map 
will apply to.
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Load Loads or displays the selected map. 

Note: A map must first be selected in the Map list.

Save Saves the current map.

Save As Saves the contents of the window with a map name you choose.

Rename Changes the name of the map that’s currently selected in the map list. 

Print Prints the map displayed.

Print Preview Displays the Map window’s contents for preprint viewing.

Print Setup Sets printer characteristics.

Log On Brings up the dialog where you can type in your User ID and Passwords 
you are not already logged in.

Change Password Opens the Change Password dialog, enabling you to change your 
password (you must have the corresponding system level permission to 
do so). 

Log Off Logs you off of the MapDesigner application.

Exit Logs you out and ends your MapDesigner session. 

Edit menu

Menu option Toolbar button Function

Change 
Background

Displays the Open Map Background Image window so that you can 
load a different background graphic into the window keeping intact all 
map items. 

Insert Text Adds text to the map. 

Delete Deletes the selected item. 

Change Label Font Sets the font characteristics for every map element label on the map. 

Properties (Available only if exactly one item is selected)

• If the item is a text box, an Edit Text window displays.

• If the item is a map element, the Map Element Properties 
folder displays.

Icon Library Launches the Map Icon Library window.

Map menu (Continued)

Menu option Toolbar button Function
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How to Use the Toolbars
MapDesigner utilizes one standard Windows toolbar.

Map and System Configuration Object Lists
The left side of the main MapDesigner window is called the List window and it 
includes a Map list and a System Configuration Objects list. The Map list 

View menu

Menu option Toolbar button Function

Toolbar Displays the toolbar when checked.

Status Bar Displays the status bar when checked.

Refresh Tree Reloads the Map and System Configuration Objects lists from the 
database, making sure everything is up to date.

Window menu

Menu option Function

Split Adjusts the relative sizes of the left (List window) and right (Map window) portions of the 
MapDesigner Window.

Help menu

Menu option Function

Contents Displays online help table of contents.

Index Displays an index of online help topics.

About 
MapDesigner

Displays MapDesigner software version and copyright information.

If you want to: Procedure:

Display the name of a toolbar 
button.

Point to the toolbar button with the mouse (without clicking).

Use a toolbar button to perform a 
command or function.

Click the toolbar button using the left mouse button.

Change the toolbar from 
“anchored” to “floating”.

Change the toolbar from 
“floating” to “anchored”.

Double-click an empty space in between the toolbar buttons.

Hide or display the toolbar. From the View menu select Toolbar. A checkmark appears next to the toolbar if 
it is not hidden. Toggle the toolbar to display or hide.
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includes all currently defined maps. The System Configuration Objects list 
includes anti-passback areas and any device defined in the access control system.

The information in the List window displays in hierarchical fashion, also called a 
tree or branching arrangement. Each entry in the list contains the name of one 
area, or device. Within the System Configuration Objects list, access panels have 
the leftmost entries, sorted alphabetically. For a specific access panel, a device 
connected to it is listed below and indented to the right. Each device connected to 
those devices is listed below them and further indented. By contrast, all 
subentries of the Map list are on the same hierarchical level, since they are all of 
the same type (i.e., maps). Map list entries are sorted alphabetically.

Each type of entry is identified by a graphic or icon. These include but are not 
limited to:
Map Icons

Icon Indicates

Access Panel

Account Zone

Action Group 

Alarm Input

Alarm Mask Group

Alarm Output

Alarm Output Group

Alarm Panel

Anti-Passback Area

Camera Group

CCTV Camera

CCTV Monitor 

Door 

Fire Device
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Fire Input/Output

Fire Panel

Function List

Hazardous Location

Input Group

Intercom Exchange

Intercom Station

Intrusion Area

Intrusion Panel

Intrusion Zone

Map

Matrix Switcher

Offboard Relay

Offline Lock Panel

Onboard Relay

Output Group

Personal Safety Panel

Reader

Reader Group

Receiver

Receiver Account

Icon Indicates
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Note: For a complete list of icons open MapDesigner, select Edit > Icon Library. 
Click the Icon tab/form

You can expand and collapse the Map and System Configuration Objects lists by 
using the following symbols:

Safe Location

Video Server

Icon Indicates

Symbol Indicates

“Plus” sign. Click this symbol to expand the selected entry to its 
previous state. For example, if an entry was completely 
expanded prior to being collapsed, clicking on this button will 
completely expand the entry again.

“Minus” sign. Click this symbol to collapse all sublevels of the 
selected entry.
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Chapter 3: Create and Print a Map

The Font, Map Element Properties, and Print Preview windows are used to create 
and print maps.

Map Element Properties Folder - Text Form
The Map Element Properties folder/window contains the Icon and Text forms/
tabs. The Icon form/tab is used to assign a map icon or icon group to a map 
element. To learn about the fields and buttons available on the Icon tab refer to 
Map Element Properties Folder - Icon Tab on page 39.

The text form/tab is used to enter customized text for map elements.

Field or button Description

Text area Enter customized text here, up to 2000 characters. To edit text, right-click and select any of the 
options (cut, copy, paste, delete, select all, undo text changes).

OK Saves changes made on all the forms/tabs and closes the dialog.

Cancel Exits the window without saving any text changes.

Apply Applies the changes to current map but does not close the Map Element Properties window.

Help Display online help for this topic.
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Font Window for Text Boxes
The Font window for text boxes is slightly different than the Font window for 
labels. 

Field or button Description

Text Enter the text you want to display on the map.

Font Lists fonts available on your computer. Select the font in which to display the text.

Font style Specify a style for the selected font. Choose Regular, Bold, Italic, or a combination of these. 
Different fonts have different options available.

Size Choose the character size, measured in points. The larger the number, the larger the characters 
will be.

Strikeout Puts a horizontal line through text in the Text field.

Underline Underlines text in the Text field.

Color Choose a text color.

Alignment Choose the way the text is positioned within the text box. You can select left, center, or right.

Sample Displays part or all of the text you enter in the Text field and its attributes.

OK Closes the Font window and inserts the text box on the map.

Cancel Closes the Font window and cancels your changes.
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Print Preview Window
Because the Print Preview window is used in other applications, some of the 
window’s buttons are not relevant for MapDesigner. 

Field or button Description

Print Opens the Print window from which you can set print attributes and print the map.

Next Page This button is not used in the MapDesigner application.

Prev Page This button is not used in the MapDesigner application.

Two Page This button is not used in the MapDesigner application.

Zoom in Magnifies the map. There are three levels of magnification/demagnification.

Zoom out Demagnifies or reduces the map. There are three levels of magnification/demagnification.

Close Closes the Print Preview window.

Preview area Displays the current map. You can change the displayed view by clicking the [Zoom In] or 
[Zoom Out] buttons.
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Create a Map - Process Summary
The process of creating an access control system monitoring map is simple and 
straightforward. Just follow the steps listed below. Refer to the associated 
procedures for detailed instructions.

1. Create a background.

2. Log into MapDesigner. You will automatically be in “new map” mode. For 
more information, refer to Log In/Out of MapDesigner on page 19.

3. Load a background (into the Map window).

4. Optional - Resize a background.

5. Place map elements on a background. Map elements are map icons with 
labels that represent access control hardware or anti-passback areas.

6. Optional - Customize text for map elements.

7. Optional - Add text boxes.

8. Save a new map.

Note: Procedures to Preview and Print a map are also provided in this chapter.

Procedures to Create A Map

Create a Background
Each map uses a background as its foundation. A background is a graphic file 
that contains a blueprint or map of a facility or area. If such a file doesn’t exist, 
you can create one on paper and scan it into the network or you can create it 
using a graphics or paint software program. 

Important: You cannot use MapDesigner software to create a map background.

GIF files are not 
supported.

The access control system supports the following image formats:

File Format Description File 
Extension(s)

Adobe Photoshop PSD

AutoCAD DXF DXF

CALS Raster CAL

Encapsulated Post Script EPS
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Load a Background
When you load a background you insert its graphic file into the Map window.

1. To load a background for a new map or to replace the background of an 
existing map, do one of the following:

Fax/Delrina WinFax FAX

GEM/Ventura IMG IMG

IBM IOCA (Image Object Container Architecture)
(first page supported only)

ICA

JPEG/JIFIF File Interchange Format JPG, JIF

Kodak Photo CD PCD

Kodak FlashPix FPX

Lead CMP

Macintosh PICT PCT

Mac Paint MAC

Microsoft Paint MSP

Portable Network Graphics (GIF replacement) PNG

Targa RAS, TGA

TIFF (Tagged Image File Format) TIF, MPT

Windows Bitmap BMP, DIB

Windows Metafile EMF, WMF

WordPerfect Graphic WPG

Zsoft PCX/DCX DCX, PCX

File Format Description File 
Extension(s)
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Toolbar shortcut • Click the Background toolbar button.
• Select New from the Map menu. 

2. If you are using a segmented database, you will be prompted to select a 
segment to associate with the map. 

3. The Open Map Background Image window displays. 

4. Use the Look in drop-down list and adjacent buttons to navigate to the drive 
and directory of your choice. Then select the background. 

5. Click the [Open] button, or double-click the filename to insert the selected 
image into the Map window.

Resize a Background
You can change the size of the background image within the Map window.

1. Position the mouse pointer over the black, square dot located in the lower 
right corner of the box that surrounds the image. You may need to use the 
scroll bars to locate the black, square dot.

Double-headed arrow 2. The pointer becomes a double-headed arrow. Click and drag to 
simultaneously change the width and height of the image. The aspect ratio 
(relationship between height and width) is maintained when you resize the 
image.

3. Release the mouse button when the background reaches the desired 
dimensions.

4. If you add map elements and text boxes before you resize the background, 
the map elements and text boxes automatically move to maintain their 
relative positions on the map. However, they are NOT resized.
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Place Icons on a Background
Once you have loaded a background into the Map window, you can place icons 
representing access control system hardware components, areas, or action groups 
on the background.

1. Open a map. For more information, refer to Display a Map on page 26.

2. Expand the Map list and the System Configuration Objects list. For more 
information, refer to Map and System Configuration Object Lists on 
page 22.

3. Click and drag map icons from the List window to the Map window. Place 
the icons in positions corresponding to the physical locations of the 
hardware component or area.

4. If the icon does not exist in the system configuration objects list you must 
configure it in System Administration and associate the device or area with 
the same segment as your map is associated with.
• For procedures on defining a device or area search for the device name 

or search for anti-passback areas in the System Administration User 
Guide or help file. 

• After the device or area is defined in System Administration, select 
Administration > Download Entire System. When you open 
MapDesigner the device should be listed in the System Configuration 
Objects list.

• If MapDesigner is already open refresh the view by selecting Refresh 
Tree from the View menu.

5. Once an icon is placed on the map, you cannot drag it off the map. To 
remove it, you must follow the Delete Map Items procedure on page 44.

Map icon 6. You can also link maps together by placing map icons on your map. In 
Alarm Monitoring when an Operator clicks the map icon a new map 
displays. This is useful in situations where you have both a general facility 
map and more detailed maps of areas within the facility. Someone using 
Alarm Monitoring can display the first map and if necessary view a more 
detailed map by clicking the map icon.

Customize Text for Map Elements
Customized text, up to 2000 characters, can be added to a map element. This text 
displays in Alarm Monitoring maps as a tool tip.

1. Display a map in MapDesigner.

2. Right-click a map element and select Properties.

3. The map element properties window displays. Click the Text tab/form. For 
information about the fields and buttons available on the Map Element 
Properties Window, refer on page 29 at the beginning of this chapter.

4. Enter up to 2000 characters of text. 
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Note: You can right-click the text to cut, copy, paste, delete, select all, and undo 
text changes. 

5. Click the [OK] button.

6. Save the map.

Add Text Boxes
You can add text boxes anywhere on a map and each box can contain any 
information you want. All text boxes are formatted the same.

Toolbar Shortcut 1. Click the Text toolbar button or choose Insert Text from the Edit menu

2. Position the mouse where you wish to add text, then click and drag to create 
a text box shown below. 

3. As soon as you release the mouse, the Font window displays. For more 
information, refer to Font Window for Text Boxes on page 30.

4. In the Text field, enter the text you want to place on the map.

5. Choose any text characteristics you want. Keep in mind that color is 
especially important. For example, white text will not be visible on a white 
background.

6. Click the [OK] button to close the Font window. 

Save a New Map
1. To save a new map, do one of the following:

Toolbar Shortcut • Click the Save toolbar button.
• Choose Save As from the Map menu.

2. The Save Map As window displays. Enter a descriptive map name of up to 
255 characters (you can use spaces).
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Notes: Each map must have a unique name. If you attempt to save a map using the 
name of an existing map, the following error message appears:

Click [OK] to close the error message. 

Repeat steps 1 and 2, entering a unique name for the map.

3. Click the [OK] button to close the Save As window. The map name is added 
to the Map list.

Preview a Map
You can view a map prior to printing it.

1. With a map displayed in the Map window, choose Print Preview from the 
Map menu. 

2. The Preview window displays. To view the Print Preview window, refer to  
on page 31 at the beginning of this chapter.

3. The map resizes to fit the window, while maintaining its width-to-height 
ratio.

4. Because the Preview window is used in other applications, some of the 
window’s buttons are not relevant for MapDesigner. The buttons that are 
useful for map preview are described below. 
• [Print] - opens the Print window, from which you can print or set print 

attributes (refer to the “Print a Map” procedure).
• [Zoom In] - magnifies the map and page images within the window. 

There are three zoom states (levels of magnification).
• [Zoom Out] - reduces the map and page images within the window. 

There are three zoom states (levels of magnification).
• [Close] - closes the Preview window.

Print a Map
There are four ways to print a map.

1. From within the MapDesigner window, do one of the following:
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Toolbar Shortcut • Click the Print toolbar button.
• Choose Print from the Map menu.
• Press <Ctrl> + <P> on your keyboard
• Click the [Print] button from within the Preview window 

2. A standard Print window displays. Refer to your Windows user 
documentation if you need assistance. Note that each map has only one page 
to print.

3. Select print characteristics. 

4. Click the [OK] button to print the map.
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Chapter 4: Modify Existing Maps

The Map Element Properties folder/window and the Font window is used when 
modifying existing maps.

Map Element Properties Folder - Icon Tab
The Map Element Properties folder/window contains the Icon and Text forms/
tabs. The Icon form/tab is used to assign a map icon or icon group to a map 
element. The text form/tab is used to enter customized text for map elements. For 
information on the Text form/tab, refer to Map Element Properties Folder - Text 
Form on page 29.

Field or button Description

Single icon (use the same icon for 
all hardware states):

Displays individual icons to represent the associated hardware, regardless of its 
state.

Icon group (use a different icon 
for each hardware state):

Displays icon groups which contain icons to represent different states of the 
associated hardware.

Icon Library Launches the Map Icon Library window which allows you to add/modify/
delete custom map icons and icon groups. The Icon Library window is also 
used to select which icon or icon group will be automatically assigned to a 
newly inserted map element. 

OK Saves changes made on all the forms/tabs and closes the dialog.
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Font Window for Labels

Cancel Exits the window without saving any of the icon/icon group selections. 
However, the changes made in the Icon Library folder/window (launched by 
pressing the [Icon Library] button) will not be cancelled.

Apply Applies the changes to current map but does not close the Map Element 
Properties folder/window.

Help Display online help for this topic.

Field or button Description

Font Lists fonts available on your computer. Select the font in which to display the text.

Font style Specify a style for the selected font. Choose Regular, Bold, Italic, or a combination of these. 
Different fonts have different options available.

Size Choose the character size, measured in points. The larger the number, the larger the characters 
will be.

Strikeout Puts a horizontal line through the label.

Underline Underlines the label.

Color Choose a label color.

Field or button Description
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Procedures to Modify Existing Maps

Load an Existing Map
For more information, refer to Display a Map on page 26.

Replace An Existing Background
For more information, refer to Load a Background on page 33.

Select Map Components
Text boxes are blocks of 
text add to a map. A map 
element is a map icon 
and its label.

There are several ways to select individual or multiple items (text boxes and map 
elements). Once an item is selected you can delete, move, resize, and edit its 
properties. Once multiple are selected you can delete or move all the items in the 
group simultaneously.

• To select one item and deselect everything else click the item.

• To select multiple items click and drag (just like drawing a text box) over 
multiple items.

• <Ctrl> + clicking a specific item alternates between selecting and 
deselecting that item WITHOUT affecting any other selection.

• To deselect everything click an empty space.

Script Determines the style of writing.

Sample Displays part or all the label attributes.

OK Closes the Font window and applies the font changes.

Cancel Closes the Font window and cancels your changes.

Help Displays online help information.

Field or button Description
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Change the Size of Text Boxes

Note: Do not confuse changing text boxes with changing map element labels. 
These procedures apply to text boxes only.

1. Select a text box. For more information, refer to Select Map Components on 
page 41.

2. Position the mouse over one of the square black dots (handles) that border 
the text box. Notice handles are black in color so they won’t be visible over a 
black background.

Double arrow a. The pointer becomes a double arrow. Click and drag the box to resize it.

Note: As you adjust the text box size the word wrap feature may place words on 
multiple lines. However, individual words may be truncated, cut off, if they 
do not fit the box. The alignment you chose in the Font window may also be 
a factor.

Change the Content and Font Attributes of Text Boxes

Note: Do not confuse changing text boxes with changing map element labels. 
These procedures apply to text boxes only.

1. To change text content and font attributes. Do one of the following:
• Double-click the text box to display the Font window.
• Select the text box then select Properties from the Edit menu.
• Right-click the text box, then select Properties.
• Select the text box then press <Alt> + <Enter>.

2. The Font window displays. Edit the text and font attributes. For more 
information, refer to Font Window for Labels on page 40.
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Move Text Boxes and Map Elements
4-headed arrow Position the mouse pointer over the text box or map element. When the pointer 

becomes a 4-headed arrow click and drag the item to its new location.

Change the Appearance of Map Element Labels
Map element label When you modify the appearance of labels, the change is global. This means that 

unlike text boxes, all map element labels on the map will change. 

1. To change label characteristics, do one of the following. It’s not necessary to 
first select a map element.
• Select the Change Label Font option from the Edit menu
• Right-click anywhere on the map. Then select the Change Label Font 

choice from the popup menu.

2. A Font window (somewhat different from the text box Font window) 
displays:

3. Select the font characteristics (font name, color, size, style, and effects) you 
want.

4. Click the [OK] button to close the Font window. The map displays the 
characteristics you selected.
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Change a Map’s Name
1. To change the name you’ve assigned to a map, highlight the current name in 

the Map list. 

2. Do one of the following:
• Choose Rename from the Map menu.
• Press <spacebar> on your keyboard.

3. Enter the new name.

Save an Existing Map
If you make changes to an existing map (one that has already been saved) and 
you want to save it using the existing map name do one of the following:

• Click the Save toolbar button.
• Choose Save from the Map menu.
• Press <Ctrl> + <S> on your keyboard

To save the map using a different name choose Save As from the Map menu. 
Both map names display in the Map list. 

Delete Map Items
You can delete individual or multiple items (map elements and/or text boxes) on 
a map.

1. Select the item(s) you wish to delete.

2. Do one of the following:
• Right-click, then select Delete from the popup menu.
• Choose Delete from the Edit menu.
• Press <Delete> on your keyboard.

3. The item is removed from the map. You will not be warned first.
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Delete a Map
1. Select the name of the map in the Map list of the List window.

2. Do one of the following:
• Choose Delete from the Edit menu.
• Press <Delete> on your keyboard.

3. The status bar indicates “Deleting map” and a window similar to the one 
below displays.

4. Click the [Yes] button. The map name is removed from the Map list.
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Chapter 5: Manage Map Icons and Icon Groups

MapDesigner has the ability to graphically represent the current state of a 
hardware device. For example, the map element for an alarm output can be set up 

so its icon changes from  to  when the state of the output device goes from 
active to normal. 

This is done in MapDesigner by assigning multiple map icons to the map 
element, one icon per possible device state. (Alarm Monitoring displays only one 
icon at a time for a device. When multiple states are active, it will display the 
icon for the highest priority state, using the priority scheme shown on the table 
below.)

The set of possible graphical device states depends on the device type (hence 
map element type). Refer to the table below for examples of map element types 
and their device states.

Note: For a complete list of map element types and their device states open 
MapDesigner, select Edit > Icon Library. Click the Icon Groups tab/form. 

Map Element Status Options

Map element type Device state(s) in order of priority

Access Panel Offline, Tamper, Power Failure, Normal

Alarm Input Offline, Active, Fault, Masked, Normal

Alarm Mask Group Offline, Normal

Alarm Output Offline, On, Normal (Off)

Alarm Panel Offline, Tamper, Power Failure, Normal

Function List Offline, Normal

Input Group Normal

Map Link Normal

Output Group Normal

Reader Offline, Forced, Held, Tamper, Fault, Unlocked, Locked, Power Failure, 
Masked, Normal

Reader Group Normal (Icon Groups not applicable.)

Text None (Neither Icons nor Icon Groups are applicable.)
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Map Icon Groups
Multiple map icons are assigned to a map element as map icon groups. Each map 
icon group has a name, an associated map element type and one icon per each 
device state. For example, the device for an element of type Alarm Output can 
have three graphical states: Normal, Offline, and On. The stock icon group for 
Alarm Output elements has the following icons:

Note: Stock icons and stock icon groups are those icon/icon groups, which ship 
with the access control system and cannot be renamed, modified or deleted. 
(The database upgrade installs one normal-state stock icon per each map 
element type and one stock icon group per each device map element type). 
Custom icons and icon groups are created by MapDesigner users and can be 
modified/deleted. A default icon/icon group is a stock or custom icon/icon 
group that MapDesigner automatically assigns to a newly inserted map. 

Map Icon Group Procedures

Assign a Map Icon Group to a Map Element
When you assign a map icon group to a map element, Alarm Monitoring 
operators that view a map will see a different icons for the same map element, 
depending on the state of the device/map element. For example the icon for a 
reader when it is offline will be different than the icon for the same reader when it 
is masked.

Note: This procedure does not apply to anti-passback areas, input or output groups, 
reader groups or links to other maps. Only one icon can be assigned to these 
types of elements. 

1. Launch the Map Element Properties dialog by right-clicking the element and 
selecting Properties.

2. Select the Icon group (use a different icon for each hardware state): radio 
button.

3. Choose an icon group.
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Note: Both stock (default) and customized groups for the type of map element you 
are editing will be listed.

4. Click the [OK] button.

Assign a Single Map Icon to a Map Element
When you assign a single map icon to a map element, Alarm Monitoring 
operators that view a map will see the same icon for a map element, regardless of 
the state of the device/map element. 

Note: “ALARM” still flashes above the element when it is in alarm state but the 
icon itself does not change.

1. Launch the Map Element Properties dialog by right-clicking the element and 
selecting Properties.

2. Select the Single icon (use the same icon for all hardware states): radio 
button.

3. Choose an icon from the lists of icons.
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Map Icon Library Folder

Functions: • Manage map icons, icon groups, and default icon / icon group assignments 
to newly inserted map elements.

Displayed by: • Selecting Icon Library from the Edit menu.

Note: To see changes to the icon library made by other workstations press the 
[Reload] button in this dialog or exit and re-launch MapDesigner.

Map Icon Library Window

Form element Comment

OK Saves changes made on all the forms/tabs closes the dialog.

Cancel Closes the dialog, aborting any changes made in all the forms/tabs.

Reload Reloads the icon library (all the icons, icon groups and the default icon configuration) 
from the database, aborting any changes made in the forms/tabs since the last time the 
Map Icon Library window was brought up.

Help Displays online help for this topic.
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Map Icon Library Folder - Icons Form

Functions: • Add/modify/delete custom map icons.

Displayed by: • Selecting Icon Library from the Edit menu.

Map Icon Library Window

Note: Changes are not written to the database until you click the [OK] button. 

Icons form

Form element Comment

Display window Lists icons currently available.

Add Adds a new icon. 

Modify Changes the image for an icon.

Delete Removes an icon.

Rename Changes the name of an icon.
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Icons Form Procedures

Add a Custom Icon
1. Display the Icon Library window by selecting Icon Library from the Edit 

menu.

2. Click the [Add] button. 

3. The Choose Icon Image window displays. Navigate to your new image and 
select it.

4. Click the [Open] button. The icon is inserted into the icon list and requires 
you to type in a unique icon name. In the example below, an icon in the 
shape of a bell is added.

5. Type in the name for the new icon. In the example above, the new icon is 
named “Alarm”.

Note: You cannot assign a name that already exists. If you want to replace the 
image of a custom icon or change the name of its label, refer to Modify or 
Delete Custom Icons on page 53. It is not recommended that you change the 
image or label of a stock icon.
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Modify or Delete Custom Icons
You can modify and delete any graphic map element you create as well as 
rename its label.

1. Do one of the following:
• Right-click a map element and select Properties.
• Select a map element and select Properties from the Edit menu.

2. The Map Element Properties folder/window displays. Click the [Icon 
Library] button. 

Note: Although all graphics appear to be of equal size on the Icon form, they 
display at their original size when placed on the map. For this reason, it is 
recommended that any icon you add be no smaller than 10 x 10 pixels and no 
larger than 30 x 30 pixels. The default icon provided with MapDesigner 
average approximately 20 x 20 pixels. 

3. The Icon Library folder/window displays. In the Icon Library form/window 
you can perform the following:
• Add an icon. Clicking the [Add] button displays a window from which 

you can select a graphic file to use as a map icon. Select the graphic and 
click the [Open] button. The image is replaced and the cursor flashes in 
revision 45 — 53



5: Manage Map Icons and Icon Groups
the label field. Enter a label for the icon and press <Enter>. For more 
information, refer to Add a Custom Icon on page 52.

• Modify an icon. Clicking the [Modify] button after you select an icon 
displays a window from which you can select a new graphic file. Select 
the graphic and click the [Open] button. The image is replaced. 

• Delete an icon. Selecting the [Delete] button after you select an icon 
removes it from the database. No warning message displays.

• Change a label. Clicking the [Rename] button after you select an icon 
highlights the icon label. Enter the new label name and press <Enter>.
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Map Icon Library – Icon Groups form

Functions: • Allows you to add/modify/delete custom map icon groups.

Displayed by: • Selecting Icon Library from the Edit menu and clicking the Icon Groups 
form/tab.
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Map Icon Library Window

Icon Groups Form Procedures

Add a Custom Icon Group
1. Display the Icon Groups form by selecting Icon Library from the Edit 

menu and clicking the Icon Groups form/tab.

2. Select the group in which you wish to add a custom icon group. 

3. Click the [Add] button.

4. A new group is added with the stock icon. Type in a unique group name.

5. Click the [OK] button.

6. If you want to assign different icons to the various device/element states, re-
open the Icon Groups form by selecting Icon Library from the Edit menu 
and clicking the Icon Groups form/tab.

Icon Groups form

Form element Comment

Display window Lists all the map icon groups in the system in a hierarchical tree-like fashion. The root 
(left-most) level lists each map element type with its stock icon displayed to the left of its 
name. Each map icon group for a specific map element type is listed in a sub-tree off of 
that map element type with its normal state icon displayed to the left of its name. Each 
possible graphical device state for a group’s associated map element type is listed in a 
leaf node off of the group node in the order of priority Alarm Monitoring uses when 
determining which icon to show for the current device state. The icon for a device state is 
displayed to the left of its name. 

Icon for currently 
selected state

Lists all icons currently defined to the system. When the device state for a custom icon 
group is selected in the icon groups tree above it allows you to assign which icon is to be 
used for that state. Otherwise it is disabled out, as shown above.

Add Add a new icon group. 

Delete Remove an icon group.

Rename Change the name of an icon group.
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7. Navigate to the custom icon group you just created.

8. Select the “old” device/element status icon.

9. In the Icon for currently selected state listing select the new graphic.

10. Repeat step 9 for each device/element state. 

Note: Changing the icon for the normal device state also changes the icon shown to 
the left of the icon group name in the icon groups tree.

Rename a Custom Icon Group
Stock icon groups cannot be renamed.

1. Display the Icon Groups form by selecting Icon Library from the Edit 
menu.

2. Select the icon group to be renamed.

3. Click the [Rename] button. 

4. Type in the new name for the icon group.

5. Click the [OK] button.

Delete a Custom Icon Group
Stock icon groups cannot be deleted.

1. Display the Icon Groups form by selecting Icon Library from the Edit 
menu.

2. Select the icon group(s) you wish to remove. 

3. Click the [Delete] button. 

4. The icon group is removed without prompting for confirmation. 

5. Click the [OK] button. The icon group is deleted from the database, and the 
Map Icon Library window closes.
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Map Icon Library Folder - Default Icons Form

Functions: • MapDesigner lets you configure which icon or icon group is to be 
automatically assigned when inserting a new map element of a specific type 
into a map. This configuration is stored in the database and is global to the 
system (i.e. it is for all maps and all MapDesigner users). 

Displayed by: • Selecting Icon Library from the Edit menu and clicking the Default Icons 
form/tab.
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Map Icon Library Window

Default Icons form Procedures

Select Default Map Icons and Icon Groups
Either a single icon or a icon group can be the default for any newly inserted map 
element of the following type: Access Panel, Alarm Input, Alarm Output, Alarm 
Mask Group, Alarm Panel, Function List, or Reader. To configure MapDesigner 
to automatically assign a map icon group to newly inserted elements of a 
particular type:

1. Display the Default Icons form by selecting Icon Library from the Edit 
menu and clicking the Default Icons form/tab.

2. Select that map element type in the Default icon or icon group for new 
map elements list.

3. Select the Default to the following icon group: radio button.

4. Choose an icon group and click the [OK] button. 

Default Icons form

Form element Comment

Default icon or icon 
group for new map 
elements:

This section consists of two lists: Map Element Type, which lists the various elements 
that can appear on a map, and Default Icon / Icon Group, which lists its corresponding 
image. 

Default to the following 
icon:

Choose default icons.

Default to the following 
icon groups: 

Choose default icon groups. 
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